Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Benelli Forums
NJgunner

SBII Jamming update

Recommended Posts

Those of you who know, I had problems with my SBII jamming on the frist shot of an outting only. I broke the gun in with 3 boxes of high brass without any problems. A few different pheasant hunts It would fail to eject the shell. I was using Federal Wing Shok 4dram 1 1/4oz shot. I then went deer hunting and two seperate hunts with 3.5" buckshot did not have any problems. I recently cleaned the entire gun including the recoil tube and added about 6 drops of clp in it. Benelli told me to try different ammo so i used remington 3 3/4 dram express long range and it didnt jam on the first shot so im happy for once BUT the ammo it was jamming with would cycle fine AFTER the first shot so who knows. I have a couple questions

 

#1

How many drops clp or oil do you guys use on the bolt rails? I usually bolt one on each side of the bolt itself and spread it around then 1 on each side of where the bolt rail slides inside of the gun.

 

#2

When the gun would jam I beleive the bolt was almost locked back and you would have to give it a push forward. If you guys pull back on the bolt and push it forward and do this a bunch of times can you sometimes get it to hangup to the point you can take your hand off and its locked back and then you have to give it a little push forward to get it going? My gun is like this as sometimes when i do this motion I feel some resistance when the bolt is all the way back and just about to go forward is this normal?

 

#3 Are you guys oiling all moving parts in the trigger assembly?

Share this post


Link to post
Share on other sites

Tight choke? for what hunting deer or turkey? Use full or try for a turkey choke thats benelli compatable if there is one.

Share this post


Link to post
Share on other sites

Nj...i've had my SBE2 since last Dec o7...hav'nt had any problems with it.I've shot over 700 rounds threw it ..i clean it like any other shotgun of My'in nothing special...i do slightly wipe every moving part with FP-10 Elite Lubicant as for the CLP i clean with it and wipe it off..and then use the FP-10...and lightly wiping the trigger housing.I must be one of the lucky ones cause 'ive been hearing horror stories and hav'nt had not one problem with it and do alot of hunting in marshes and salt water...Honkers41

Share this post


Link to post
Share on other sites

I'm useing Kicks Chokes for my ducks and goose hunting, they seem to be the tightiest out of my SBE2,also i use the Briley crio waterfowl chokes for passing ducks..for turkey try the .665 Benelli ExtraFull choke or the Kicks Turkey choke.One imporant thing i'm forgetting i shoot blackcloud out of my briley chokes and Federal and winchester Steel out of my Kicks Chokes...either chokes will get you the patterns you want.Honkers41

Share this post


Link to post
Share on other sites

I had the same problem with my SBE II the first week of September. It only did it once though. Since that trip, I have applied a very light coat of CLP to both the bolt and the rails and it hasn't happened since. Although, I've only put between 3 and 4 boxes of shells through it so far. Two weekends ago, I got a stovepipe but no other problems since. I'm inclined to believe it's a break in problem that will go away in time. Assuming you properly lubricate the gun.

Share this post


Link to post
Share on other sites
I had the same problem with my SBE II the first week of September. It only did it once though. Since that trip, I have applied a very light coat of CLP to both the bolt and the rails and it hasn't happened since. Although, I've only put between 3 and 4 boxes of shells through it so far. Two weekends ago, I got a stovepipe but no other problems since. I'm inclined to believe it's a break in problem that will go away in time. Assuming you properly lubricate the gun.

 

I hope your using high brass, thats what the gun needs for the first 3-4 boxes

Share this post


Link to post
Share on other sites

I was using 3 inchers for ducks and 3 1/2 inchers when hunting geese. I have put a couple rounds of light field loads through it too with no problems. I think some these guns just need a break in...some more than others. If you're still havin problems, I'd send it back to Benelli. I think they'll take care of you.

 

I shot two ducks last Saturday while fishin for coho salmon. It's gettin cold up here now though, (-4 degrees this morning) and most ducks and geese are headed south. So, I'm breakin out the Browning Citori 625 Field I just bought to go chase bunnies and grouse. Good huntin!

Share this post


Link to post
Share on other sites

NJ,

may be a late reply on this post but..

 

I've had a few fail to ejects with my SBE2 as well- specifically with the federal 1 3/8 oz No 5's (1500fps). Every other shell has cycled perfectly (~750 rounds, everything from 2 3/4 1oz to 3 1/2 BB). I've had 2 FTE's on the same day (30 rounds) and my buddy with a SBE2 lefty had the same problem (different box of shells).

 

I'm curious how others have had the shell jam- mine seems to eject the spent shell but it gets stuck horizontally (new shell blocked from chambering by the brass end of the spent one). Like I said its only happened a couple of times but thats two lost birds =)

 

1n

Share this post


Link to post
Share on other sites
NJ,

may be a late reply on this post but..

 

I've had a few fail to ejects with my SBE2 as well- specifically with the federal 1 3/8 oz No 5's (1500fps). Every other shell has cycled perfectly (~750 rounds, everything from 2 3/4 1oz to 3 1/2 BB). I've had 2 FTE's on the same day (30 rounds) and my buddy with a SBE2 lefty had the same problem (different box of shells).

 

I'm curious how others have had the shell jam- mine seems to eject the spent shell but it gets stuck horizontally (new shell blocked from chambering by the brass end of the spent one). Like I said its only happened a couple of times but thats two lost birds =)

 

1n

 

Ill tell you what, I thought it was the load also. I removed trigger troup and cleaned/lubed as well as heating up the screw on the end of the recoil tube and removed the spring and plunger, I then used a 20gauge soft brush to clean out the tube. 6 drops of clp and reassembled. I also made sure to put 1 or 2 drops of CLP inside where the bolt rides and lubed the bolt face that rotates and rails. I went pheasant hunting saturday and today with a total of 6 rounds fired with the same federal ammo with no problem. Beleive me I was close to sending the gun back, I think it just needed the things that I did.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...