Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Benelli Forums
Rost

Problems after 13th season with my M1...

Recommended Posts

Hello,

 

After 13 seasons, my M1 is finally giving me some grief. I am wondering if any other benelli owners can help me out.

 

First, a little gun background. The gun has an estimated 8,000+ rounds through it. It's been fairly well maintained (meaning I clean it when it's dirty). Most rounds have been waterfowl rounds and trap. I also put a heavy spring in it back in 1999.

 

Now for my issues...

1. My 2nd round is not getting kicked up into the chamber after the first round is ejected. It gets thrown down from the magazine, but the lifter is not sending it up into the chamber.

 

2. Has anyone else had to replace the firing pin? I've had a few rounds not go off in the past week. Upon inspection, I've noticed that the primer is not really getting punched very hard.

 

3. Are there any parts besides the recoil spring that are known to wear out I should consider replacing to ensure this gun will remain reliable? I'd like to give it a "mini overhaul".

 

Any help will ba appreciated.

 

Thanks

Edited by Rost

Share this post


Link to post
Share on other sites

Hmm..8,000 rounds eh? I would think its entirely possible, and likely, that several parts may need replacing at this point. In terms of the firing pin...Have you visually inspected it? Its possible that the firing pin spring may be on the brink of wearing out. Firing pins arent too expensive, so it might be a wise investment. In terms of your feeding issue, Im not sure. I would be looking at the mag tube spring first. If not that, I cant say. If you were having FTE probs then, of course, I would suspect a weak extractor/ejector. Anyway, I would think of springs first...hardware second. Kinda similar to semi-auto pistols.

 

Either way, do you have a trusted gunsmith nearby? I would just have him take a look at it and see what may or may not need replacing at this point.

Edited by shotgunNoob

Share this post


Link to post
Share on other sites
Guest Serial Crusher

I would suspect a combination of a strong recoil spring and a weakened tube spring, with lighter loads it may occasionally be slowed enough to FTF. It's probably hit and miss right now because of the different amounts of recoil you take up from the system in various firing positions. If you're seeing weak hits on primers it could be a few different things, but firing pin and spring are the cheapest possibility. If you get bored you could try to play with cycling the action by hand and checking the trigger reset **outside, after triple checking it is empty**. I don't know if the armi system will fail in this way, but it maybe that worn parts are allowing the hammer to follow the bolt forward on an incomplete trigger reset. You should definitely talk it over with a gun smith in any case.

Share this post


Link to post
Share on other sites

Okay, confession to make. Maybe I didn't clean it from "head to toe" before as I had said. I took apart the bolt tonight (this is something I usually do once a year) and discovered that my firing pin was seriously gooped up.

 

I also actually took the recoil spring out and cleaned it rather than just spraying cleaner into the tube.

 

Soo... I'll give this another try tomorrow and let you know how things went.

Share this post


Link to post
Share on other sites

Rost:

Is the bolt locking back with a round sitting on the lifter? If so, when is the last time you pulled the trigger group and cleaned it?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...