Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Benelli Forums
Sawyer

Super Black Eagle 2 Problem

Recommended Posts

the light load assembly ( part number 190G ) in the spare parts book in my sbe2 is broken. the nipple like pin at the end of it has broken off. you can tell were it has been hitting the stock retaining nut screw ( part # 050G )

 

the gun is not that old, bought in february of last year. had been shot maybe 2-300 times untill duck season this past year. it was shooting fine untill i bought some of those remington hypersonic shells. i probably shot 5 boxes of 3 1/2 #2 through it with no problem, then it started not ejecting the first shot. i noticed i couldnt even pull the bolt back to eject the shell myself.

 

i personally think it was caused by the shells, this is the 2nd sbe2 ive owned and never had the first problem out of either one untill this occurrence, but im no expert. any opinions?

 

last, is this something benelli would fix or am i going to have to order the parts from somewhere? if its not that expensive of a fix i would rather order the parts since turkey season is coming up. also, if i do have to order parts, does anyone know where i could order them? ive not been able to find them anywhere on the net.

 

thanks

Edited by Sawyer

Share this post


Link to post
Share on other sites

I see no reason why Benelli would not cover the fix. I'd suggest that you call them and speak to customer service to get a repair authorization. I'm quite sure they would cover it.

Share this post


Link to post
Share on other sites
the light load assembly ( part number 190G ) in the spare parts book in my sbe2 is broken. the nipple like pin at the end of it has broken off. you can tell were it has been hitting the stock retaining nut screw ( part # 050G )

 

the gun is not that old, bought in february of last year. had been shot maybe 2-300 times untill duck season this past year. it was shooting fine untill i bought some of those remington hypersonic shells. i probably shot 5 boxes of 3 1/2 #2 through it with no problem, then it started not ejecting the first shot. i noticed i couldnt even pull the bolt back to eject the shell myself.

 

i personally think it was caused by the shells, this is the 2nd sbe2 ive owned and never had the first problem out of either one untill this occurrence, but im no expert. any opinions?

 

last, is this something benelli would fix or am i going to have to order the parts from somewhere? if its not that expensive of a fix i would rather order the parts since turkey season is coming up. also, if i do have to order parts, does anyone know where i could order them? ive not been able to find them anywhere on the net.

 

thanks

 

 

I've run into the same issue - did benelli send you the part?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...