Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Benelli Forums
Diabolus

Sidearmor coming loose

Recommended Posts

I purchased a Sidearmor rail for my M4 and its great, but its coming loose after 80 rounds which is not acceptable.

 

I was using blue Loctite on the screws to secure it, but it doesn't seem to be holding up.

 

Am I not using enough blue Loctite, or should I be using the red Loctite?

Share this post


Link to post
Share on other sites

Try more blue locktite. I wouldn't use red on the receiver threads. I forget if SideArmor specifies a specific torque ratting for reinstallation. I was always very worried that I would strip the fine threads. If I recall, they use allen head screws right?

 

Coat the threads fully, then torque it down pretty tightly with the small angled allen key they provide. Let the locktite set for 24 hours before taking it out for another shooting session. If that still shoots loose, your threads might be damaged. So I'd then consider using red locktite. Just count on needing heat to remove it down the road. If you try to strong arm locktite, it will damage the aluminum threads.

Share this post


Link to post
Share on other sites

Thanks for the info. I have only used blue Loctite and its only been pinch tight with the allen key. I'll try re-tightening them and give it a go after 24 hours.

Share this post


Link to post
Share on other sites

With the supplied allen key, I flexed the tool slightly when applying torque. Thumb along the front of the tool, and applied torque with my pointer and middle finger. Certainly no removing a bottle cap torque by any means.

 

I sweat a little each time I've had to mess with those screws. I've heard of a lot of people overtorquing them and stripping out the threads.

Share this post


Link to post
Share on other sites

Loctite usually recommends a solvent to prep the threads - acetone, etc I think will also work - used to remove the oils from the threads and accelerate the cure. Might be the original install had some oil still left on the treads and they loctite didn't reach full shear strength?

Might also be worth a quick call to sidearmor to see if they do recommend a torque spec, although that should have been included in the instructions.

Good luck!

Share this post


Link to post
Share on other sites

Yup, I stripped one of them. It didn't take much. So be careful! Blue loctite with 24 hours of alone time does work. I blame the stripping of the screw solely on my bicep size being too immense and my rock hard forearms.

Share this post


Link to post
Share on other sites

Couple of things are going on here.

 

1. always torque to spec if there is no spec provided the internet can probably provide the torque for the size of fastener being used. here's an ok chart http://raskcycle.com/techtip/webdoc14.html

 

2. You should be using the pink/purple loctite for small fasteners also follow directions you will now need to clean the thread holes and bolts very thoroughly i recommend using brake clean instgead of acetone as it will not leave any residue or minerals behind. http://henkelna.com/us/content_data/168592_LT4985_Threadlocking_Guide.pdf usually a dab will do if done precisely.

 

3. be sure to torque evenly maybe do a pretorque of a low amount and tighten in a pattern from the inside out.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...