Jump to content

M2 - problem with Rio shells


Recommended Posts

I just bought a new M2 12 ga. and shot it for the first time this weekend for the opening day of Dove season. I was shooting Rio game loads (2-3/4", 3-3/4 drams, 1330 FPS, 1-1/4 oz, 7-1/2 shot). The first shot goes off fine. The shell ejects and the bolt closes, but successive shells are not feeding consistently. The second shell end up either still in the magazine or winds up between the bolt and the lifter.

 

I switched to Winchester low-brass target loads and shot 2 or three boxes with no problems. I also shot a few federal high-brass sheel shot with no problems.

 

I also encountered the problem where, the second and third shell shell could not be loaded into the magazine consistently. The shell binds sometimes to the point where it cannot be inserted into the magazine. When they can be loaded into the magazine, the fit is very tight.

 

We tried the Rio shells in a friend's Beretta 3901 and they worked fine.

 

When I compare the Rio shells to other 12 ga. shells, the base seems a little different - the brass rim that seats against the chamber opening is a tiny bit fatter, causing the shell to not go into the chamber in quite as far as other brand shells.

 

Has anyone encountered problems with Rio shells in their M2?

Link to post
Share on other sites

No problems with my M2 and Rios. With the load you are shooting, you should not have a "break-in" issue. That's a heavy load. I've always heard good things about Rios (I shoot them on regular basis). However, if the M2 shoots all shells okay, then you may have a bad batch. I'd try some different brands before I started trying to fix things. You might want to take a look at the mag tube and made sure nothing is jammed up in there.

 

jed

Link to post
Share on other sites

i dont have a problem with my m2 shooting anything as per rio shells i have not shot any but mine cycles and shoots the pink federals just fine.. i got the gun home cleaned it before i shot it lubed it up and it went through 100 shells easy first time out

Link to post
Share on other sites

I had a similar problem with Rio 20 gauge shells in my Montefeltro. Unlike the Federals and Estates that I normally shoot skeet with, I had both feed problems and inconsistencies with the Rio brass including a sharp edge on some shells that would seem to hang up when trying to load my magazine and secondly, not allowing the bolt head to fully rotate into the locked position with a chambered round. The gun was very clean and functioned with the Federal target loads without problem.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...