Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Benelli Forums
Sign in to follow this  
k7714

HELP PLEASE!!! Assembly issues with SBEII

Recommended Posts

Leaving to go hunting soon and i can't get the trigger assembly back into place

 

It seems to be hitting the plastic drop shim(or atleast thats where i think the issue is) the rear of the trigger assembly won't lock into place or go high enough to get the pin back in place.

 

 

any tips? tricks? anything? i really don't want to pull off the stock or have the time. and now the shim is starting to get chewed up alittle from me trying to force it in.

 

any help is greatly appreciated!!!!

 

 

Kevin

Share this post


Link to post
Share on other sites

When you put the trigger assembly back in, start by insering the back of the assembly in place first...it'll slide into place and then push the magazine feed end up..it'll fall into place. It may require some added pressure because of the tigh fit, but it will go together and the pin holes will line up. Also, do this without the bolt in place. Re-install the bolt and barrel after the trigger group has been set in place.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...