Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Benelli Forums

Recommended Posts

Hello All,

I have been hunting all morning and have been experiencing tons of problems with my SBE II. Here's the situation. My SBE is my favorite gun, and I treat it as such. The gun is immaculate and has been kept that way since I purchased it. The gun was clean when I went out to the duck blind this morning. I was shooting Hevi-Shot so I highly doubt it was not cycling because of the ammo type. The primary problem I was having was failure to feed. The gun would

fire the initial shot, then the bolt would get "jammed up" in the rear position. It was raining steadily. Any suggestions. Thanks as always.

Share this post


Link to post
Share on other sites

Not sure how long you've had the gun, but I would look at replacing the recoil spring. Mine would lock back and fail to load the next shell (even with 3.5"), and my recoil spring ended up being the culprit. It would be an easy fix, that's for sure.

Share this post


Link to post
Share on other sites

Bello..... you could be right, I didn't even think of that. I would still look at that recoil spring though. My gun did the exact same thing, locking back after the first shot, and the new recoil spring fixed it. Whether it's the mag, or recoil spring, it's still an quick/easy fix.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...