Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Benelli Forums
jimmyjoe

New SBE II Stove Piping

Recommended Posts

I have a new SBE II and have shot about 50 shells through it. I go out on opening day of duck and low and behold I miss my first 6 ducks because this gun would not eject empty shells. I am not happy, and quite honestly I am thinking about throwing this gun away and getting something else. I was shooting hevi shot 3" #3 and this gun would not eject. I switched to BC 3" #3 and it ejected no problem. One note. When is was taking this gun down I noticed how hard it was to take the barrel off, I had to almost yank it off, and on. There is a small gap where the barrel goes into the lip on the butt stock. Also, I put two small drops of Benelli oil in the frame where the bolt slides in and it feels really tight at the spring when it slides back manually. I am not real happy about loosing several weeks of my season while they fix this problem. There are know issues with some of these guns and I think it is bulls_it that when you pay this much for a gun these problems are happening. If I wanted remington problems I would have bought one!!!!

Share this post


Link to post
Share on other sites

damn man! That sucks. I don't think it should do that with them heavy of loads, but perhaps it's not broke in. Some guns need to be shot a bunch and "loosened" up so to speak. Maybe try some 3.5" shells a little? I would think that the more you shot it, she better it would get? My SBE is from 2003 and it stove piped a few times the first year I had it, but 30K rounds later, it's as reliable as it gets....Just a thought. Hope you get it figured out.

Share this post


Link to post
Share on other sites

sounds like it just doesn't like hevi-shot, or it still needs to break in. with those heavy loads though and for that price that just shouldn't happen. That being said I have a pistol that is a little finicky about the ammo I use. With the price of hevi-shot and the load that they carry there's no way it shouldn't allow your gun to fully eject the shells. break it down, clean the **** out of it, and shoot about 50 3 1/2" shells through it. After that if you're still having problems with hevi-shot don't use it. maybe the gun just has something against it.

Share this post


Link to post
Share on other sites

The first year I had my SBEII, it stove piped on me with a 3 1/2" Federal shell and it was an overhead shot...I was told on other threads that this can happen when the gun is not seated properly on the shoulder. Now, this is the only instance i had with the gun and i've had it for 6 years now...You also stated that the problem is with Hevi Shot 3inch #3. Try Hevi Metal 3inch #3...This is all I shot and never had a problem.....Don't give up on the gun....

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...