Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Benelli Forums
Sign in to follow this  
TSI

M2 Shell in tube not being grabbed intermittenly

Recommended Posts

I have a meticulously maintained 2 year old M2 Field lefty with approximately 1500 rounds that had performed flawlessly until last week while my daughter was shooting trap doubles. The second shell in the tube was not being grabbed by the carrier latch. It happened 3 times randomly in the round of 50.  Nothing new, same shells since day 1, Rio 1 1/8 oz 1200 fps 3 drams.  I took the gun home, cleaned and lubed it again(removing all parts and reassembling as usual).  Went out and fired 102 rounds 3 at a time of Rios, estates, Federals, and Nobels flawlessly.  No worse feeling than seeing your kid look back at you when the gun fails in the middle of a competition.  Any ideas?

Share this post


Link to post
Share on other sites

Are you saying the 2nd shell is not coming out of the mag tube and cycling into the chamber?

If that is the issue is the 2nd shell coming partially out of the magazine tube, but not getting far enough back into the action for the bolt to close and feed the shell into the chamber? - or is the 2nd shell not exiting the magazine tube at all?

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...