Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

benelli r 1 308


Recommended Posts

Have you asked CS which ammo they're using?

 

Has CS asked you which ammo you're using?

 

Have you tested the rifle with other loads?

 

Is it one of the first models with the index system, or does it have the new spring-lock barrel nut?

 

Have you asked someone else to shoot it, to make sure the problem isn't behind the recoil pad?

 

Are you shooting from a bench?

 

What are the groupings you are getting?

 

Have you tested yourself for flinching?

 

Has the crown been subjected to damage?

 

Has the weapon been thoroughly cleaned?

 

Have the scope and mounts been checked to see if all is well, physically and functionally?

 

[ 08-14-2006, 04:44 PM: Message edited by: tucker301 ]

Link to post
Share on other sites

i have used many different ammos. mygrouping at best is around 2.5 inches at 100 yards shooting from a vice. i have let many people see this crap for thier self. ihave asked all the questions . still no help. the last time i sent it in for repair they found no problem.

Link to post
Share on other sites

From a vise?

Anyway, the group size isn't all that bad for the given weapon.

I've seen some guys who'd be tickled to get that from their semi-auto. Not me, but some guys.

 

You need to take the feeding issues up with cutomer service again.

There's really no one here who can help you, given the information you've been able to convey.

 

[ 08-15-2006, 06:48 AM: Message edited by: tucker301 ]

Link to post
Share on other sites

Years ago I had a pre Boss BAR in 7 Mag. Best it could do was groups about the size of the palm of your hand. Find out what Benelli's standards are for the R1. You may also have magazine issues. I now have a BAR in 308 with the Boss. Bought a spare mag, didn't use it but the last day of season. I had a double feed shooting at an rapidly escaping 8 pointer. See if a new mag will solve the feeding issues.

Link to post
Share on other sites

I bet Lee is right.

 

I had a similar feeding issue a while back and read a post (here) from someone (who?) who had this issue. Turns out it was 2 things for me: 1) The magazine sides where a bit tight -- I loosened them with my multi tool (they bend easily) & 2) I found that if I didn't seat the rounds all the way back in the magazine they mis-fed this way (sometimes jaming a round in tight!) If the magazine is too tight you'll notice very distinct feeding marks -- like scrapes or gouges on the cases. This happens most likely when the bolt pushes the round out of its confined space. Check your cases for deep scratches. Mine do not show these any more since I bent the very edge of the magazine out.

 

Also, Tucker pointed out that if you have the older index nut vs spring lock this may contribute. I had mine changed. To date, no more feeding issues!

 

As far as grouping is concerned. The R1 is very selective in regards to ammo. It wasn't until I used hand loaded Sierra match kings that I got sub MOA's with my 300 Win Mag. I had also did some work with the forearm -- it was touching the barrel in spots, so I relieved it a bit and can now slip a dollar bill in between them.

 

Also, again take Tucker's very good advice with the other things he mentioned. For example "Have the scope and mounts been checked to see if all is well, physically and functionally?" Last week I treated my Ar-15 (M4 copy from Rock River Arms) to a new scope after only ever using iron sights. I expected sub MOA groups and got 3" groups -- I shot consistent 2 1/2" groups with iron sights! I was pissed and decided it was the wind (gusty 5-7 mph) until I removed the scope and found it slid back and forth on the rail 1/4". Rule #1 if you shoot poor groups with a scope check your mount!

 

The R1 is like many High-end Italian machines. It is beautifully crafted, it needs to be treated right, and when it works good -- it works great! When it doesn't -- it gets frustrating. Ask any Lamborghini or Ferrari owner.

 

Good luck,

 

Glenn

 

[ 08-15-2006, 07:52 PM: Message edited by: GlennRoss ]

Link to post
Share on other sites
  • 2 weeks later...

BTW,

 

I shot a 7/8" group today @ 100 yards (8/26/06) with "cheap" Remington 150 grain soft point 300WM ammo. Was sportin' my new Zeiss 3-9 40mm Scope.

 

And -- Yup, I blew out the scrawny Weaver rings the guy at Cabela's assured me would hold up to the recoil. LOL, 20 rounds into its inagural bench session it slid the scope over 3/4" back into the rings til it hit the adjustment knob taper. After putting 3 rounds thru the exact same hole at 25 yards and 3 rounds in a 7/8" grouping -- the next 3 rounds went all over the target. Scratching my head I recalled Rule #1: Check your scope mounts.

 

Some of you might recall that after 400+ rounds I bent the "$%^~" out of my 30mm QRW Leupold rings and had them warrantied. I've since gone to the super beefy "tactical" Leupold rings on my 1.5-5 20mm Leupold scope with no problems. This new scope is a 1" tube and I stupidly bought skinny rings. I have a Rock River Arms .223 M-4 copy that I bought it for. I figured using the 3-9 Zeiss for day at the range on my 300WM Benelli R-1 would be ok. NOT!

 

Honestly, I really Love my R-1!!! It kick's the crap out of everything including the scope rigs. BTW, it has a muzzle break. LOL.

 

-Glenn

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...