Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Benelli Forums
Sign in to follow this  
Chessie Dog

Nova 12 ga jamming

Recommended Posts

Sometimes on the second or third shot the shotgun will not fire. This has happened on my shotgun and two of my friends. We all have 2002 camo 12 ga Novas.

 

We end up shucking the shell out. Any ideas??

Share this post


Link to post
Share on other sites

my nova20 is jaming as well.This is really ticking me off.My gun is doing something different than yours but it sounds like benelli needs to smooth out some of the problems the nova's are having.I really like the feel and features of the nova but wonder if I should have gone with another brand.I think I'm going to do a pole to see who is and who isnt having problems with there nova.

Share this post


Link to post
Share on other sites
Originally posted by dovekiller:

my nova20 is jaming as well.This is really ticking me off.My gun is doing something different than yours but it sounds like benelli needs to smooth out some of the problems the nova's are having.I really like the feel and features of the nova but wonder if I should have gone with another brand.I think I'm going to do a pole to see who is and who isnt having problems with there nova.

Share this post


Link to post
Share on other sites
Originally posted by skip22:

quote:
Originally posted by dovekiller:

my nova20 is jaming as well.This is really ticking me off.My gun is doing something different than yours but it sounds like benelli needs to smooth out some of the problems the nova's are having.I really like the feel and features of the nova but wonder if I should have gone with another brand.I think I'm going to do a pole to see who is and who isnt having problems with there nova.

Skip-My 20 ga. jammed constantly back in October 02 during a dove hunting trip to south Texas. The shells were very hard to extract. Several dealers told me that if it was a new gun (which it was) it would take some time to "loosen up", but I think there are bigger problems.

Share this post


Link to post
Share on other sites

i have a nova 12g and for the past 2 years i ahve been using it for everytihng and it has never jammed on me. i guess you can try oiling it up and trying to break it in, but other than that i would call the manufacturer and see what they say.

Share this post


Link to post
Share on other sites
Originally posted by skip22:

quote:
Originally posted by dovekiller:

my nova20 is jaming as well.This is really ticking me off.My gun is doing something different than yours but it sounds like benelli needs to smooth out some of the problems the nova's are having.I really like the feel and features of the nova but wonder if I should have gone with another brand.I think I'm going to do a pole to see who is and who isnt having problems with there nova.

 

[ July 31, 2003, 07:35 AM: Message edited by: Nelly Girl ]

Share this post


Link to post
Share on other sites
Originally posted by nmarro:

i have a nova 12g and for the past 2 years i ahve been using it for everytihng and it has never jammed on me. i guess you can try oiling it up and trying to break it in, but other than that i would call the manufacturer and see what they say.

Share this post


Link to post
Share on other sites

What's everyone's feelings on barrel length. I shoot a 24" for ducks, dove and geese. I've often thought that maybe I should have gotten a 26" instead.

Share this post


Link to post
Share on other sites
Originally posted by nmarro:

i have a nova 12g and for the past 2 years i ahve been using it for everytihng and it has never jammed on me. i guess you can try oiling it up and trying to break it in, but other than that i would call the manufacturer and see what they say.

Share this post


Link to post
Share on other sites

Questions for people who have jamming problems.

Do you pump the action fully forward or shortstroke it not closed? Have you used a pump action firearm before? Have you cleaned it? Have you put it back the exact way it was before? Do you hit the bolt release during the jamming?

Share this post


Link to post
Share on other sites

I have had a couple of guys I know have a problem with that as well, but I also know a couple of other guys that have had no problems. I hope this problem gets taken care of, I was considering buying a Nova as a spare or backup gun. I own a M1 in HD Camo with the 26" barrel & extension tube, I will never own a shotgun without at least that length. It makes it so much easier to follow thru on shots as well as being more duck blind friendly to the others in there with me.

Share this post


Link to post
Share on other sites

I have been using pumps for years. I don't shoot semis at all. My black Nova did have this problem. Unfortunately it was stolen and I replaced it with a camo Nova. Mine and two of my friends are bought doing the same thing. I don't think I'm short stroking or hitting the ejector button.

Share this post


Link to post
Share on other sites
Originally posted by Eric:

Sometimes on the second or third shot the shotgun will not fire. This has happened on my shotgun and two of my friends. We all have 2002 camo 12 ga Novas.

 

We end up shucking the shell out. Any ideas??

Share this post


Link to post
Share on other sites
Originally posted by Eric:

Sometimes on the second or third shot the shotgun will not fire. This has happened on my shotgun and two of my friends. We all have 2002 camo 12 ga Novas.

 

We end up shucking the shell out. Any ideas??

I bought my Nova the first year they came out, and it has functioned flawlessly for about 4 years now. I did have problems of it jamming with 2 3/4 shells, but it was my fault, I wasn't running the action all the way back. Since I figured this out I don't have any problems. I hunt with others who have Benneli Nova's and they don't seem to have the problem either. I have shot everything from Ithaca's, Remington's and Winchester's, but this Nova has outdone them all.

I would have a gunsmith look at your action and make sure your ejection slide bars are setting in the tracks properly. In the older pump guns this use to be a problem.

Let me know how it turns out.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...