Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Benelli Forums
edwinian2327

Jamming M2

Recommended Posts

Last year I bought a 20 ga. M2 in camo finish. I used it last year for ducks and geese, no problem. This year, I tried to use on doves, but i had a problem with the second shell not cycling into the barrel. any suggestions??

Share this post


Link to post
Share on other sites

I broke it down completely and cleaned with solvent. I then applied a light coat of rem oil and wiped with a rag. i am going to try again today and see what happens. i think you might be on to something with heavier loads. Thanks!!

Share this post


Link to post
Share on other sites

Rem oil is rather thin and if the gun is new, you might want to be more liberal with a better or thicker oil like Miltec. Make sure you get some oil into the recoil assembly too, it's mostly responsible for feeding the next shell into the chamber.

Share this post


Link to post
Share on other sites

Clean off all of the rem-oil, then apply a light layer of Breakfree CLP, FP-10 or Hoppes Elite gun oil. Rem-oil is horrible, I hate that stuff.

 

If that doesn't work, use heavier shells. Also might want to send some really heavy 3" loads through the gun also. Might need more breaking in.

 

Whats the dram equivelent on the loads you're using right now?

Share this post


Link to post
Share on other sites

I agree with mudhen. If your shotgun is clean and lightly oiled it should work fine. The only shell feeding problem generally incountered is too light of load (not enough power -recoil- for the enertia system to work properly). Compare what you used last year to now. Remember to post if you fix the problem.

Share this post


Link to post
Share on other sites
Last year I bought a 20 ga. M2 in camo finish. I used it last year for ducks and geese, no problem. This year, I tried to use on doves, but i had a problem with the second shell not cycling into the barrel. any suggestions??

 

 

Since you used it for waterfowl last season, did you clean the recoil spring that runs in the but stock?

 

There is no mention anywhere that you actually cleaned it. You might want to give that a try as well. It should only take you about an extra 20 minutes the first time through. HTere are excelent instructions on how to do that here on this site. I think that they were originally posted by Tucker.

 

Mike

Share this post


Link to post
Share on other sites

I hate to bring a dead post back from the grave but I have been having the same problem. My M2 is 2 weeks old I have shot 9 3" waterfowl rounds and 2 boxes of dove/skeet shot through it. No problem with the waterfowl rounds, but sometimes the 2nd shot of dove rounds will hang up, and also when loading the dove rounds I float a shell and pull the charging handel to the rear and the shell will get hung up in the action. I have no idea what is causing this, but I hope it just needs to be broken in. I have lightly lubricated the bolt rails with the supplied lubricant. Any ideas?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...