Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Benelli Forums

woodsie

Members
  • Content Count

    16
  • Joined

  • Last visited

Community Reputation

0 Neutral

About woodsie

  • Rank
    Junior Member
  • Birthday 10/25/1976

Personal Information

  • Location
    Maryland
  • loginname
    woodsie
  • displayname
    woodsie
  1. Could it be possible my Carrier Springs on my Beneli M1 have lost thier spring. I am getting the occasional jam. The Carrier is not bringing the shell all the way thorugh to the top. Also, when I "Play" with the carrier, and push it up and down, sometiems it doesnt fall back. Is that normal. Any help is much aprpeciated. Thanks in advance, W.
  2. . I called benelli, and the guy said it does make a difference if its shouldered properly, and that could certanily be why its doing it. SO, I had some time, and since I had more hevishot to burn(100.00 worth:p ), I went to the range again, and held it to my shoulder VERY TIGHT and I didnt have one jam, untill the very last shell , when I actually remeber not holding it tight, I must have been excited, becuase in my mind, I was saying, WOW, this is working. Now I need to decided weather I can live with a gun that does not cycle all the way, if I dont shoulder it properly. I think I know the answer. W
  3. Heres how my M1 is jamming. This has happened on both my brand new M1, and my older M1. The gun stays clean, and is lightly lubed. This is with both 3" Kent TM, and Remington Hevishot My older gun had both the Surecycle spring, and the Sure Cylce mag kit. The gun, normallly on the third shell, will get stuck half way, and I hope I describe this correctly, the spent shell will eject, and the shell in the magazine will pull up, and will get stuck halfway, right in the middle of the reciever, meaning its stuck halfway between the bottom of the reciever, and the top of the reciever, and doesnt push itself forward. PLEASE HELP!, This gun fits me perfect, and I really dont want to get rid of it. Should I try another type of ammo. Any help is much appreacitated. Thanks, W.
  4. I think its OK.According to my buddy, his does that often, and his is Brand new. W.
  5. Mine is on the right side of the carrier, and it is WWWAAAYYYY more than a nick. The shell stops right at where the worn part is. W.
  6. It shot fine with my buddies trigger assymbly in my gun. I called Benelli, and they believe it has to be the groves worn in the Carrier, and are sending me a new one today. W.
  7. Not just wear and tear, but actually the carrier wearing down in one spot(about an 1/8 of an inch.), which is excactly wear the shells are getting stuck. Not sure what else it could be. Original Recoil spring back in it. Original magazine spring back in it. I put my buddies Trigger assymbly in it,Shot it about 12 times yesterday, and no jams. Guess well have to see with one more weekend of duck hunting left. Thanks, W.
  8. I think I have found my problem. Me and my buddy were looking at my trigger assembly, and on the Carrier, there are two grooves that have worn into one of the sides. This is Exactly where the shells are stopping. My buddy let me use his trigger assymbly, to make sure that was it. If this is it, this is pure wear and tear, as I probably have 30 or 40 thousand rounds through this gun. I shoot ALOT. Thanks, W.
  9. If you recall, this is my problem on my 4-5 year old M1. What happens is, I shoot, and it ejects the first shell, and while its bringing up the second shell, its getting caught in the bottom of the action, almost like its closing before it brings up the new shell, and they the action gets stuck about at the end of the brass.(plastic side) To bring the new shell up, I have to Pull back on the action, and then it slides in. Today for the first time, the gun locked back and stayed in the open position like it was empty, but it still had the third shot left.(which was in the bottom of the reciver) I dont know if this is part of the same problem. 2 weeks ago, at everyones advise, I put the Factory recoil spring back into it, and the original magazine spring. I keep it well oiled with Breakfree CLP, and it was in the 50's today. It was good for one hunt, and after that it has jammed a couple times, and today I shot a lot, and it jammed several times. One thing to note is that when I push the Carrier (long retangular metal peice on the bottom of the reciever) in and out like when cleaning or looking at it, it sometimes sticks in the upwards position. Could that be the problem. I am shooting the Kent TM 3" shells. I shoot this gun alot, both with Kent heavy shells, and a TON of Sporting Clays and skeet. During a busy month, I can easily go through a case of shells. I wonder if some pieces could just be wearing out. THANKS for your help, W. [ 01-21-2006, 05:48 PM: Message edited by: woodsie ]
  10. woodsie

    SBE problems

    From what you are explaining, I had the same problem with my M1. I had a surecylce in it and the Magazine upgrade kit. I took out both and replaced them with my factory originals, and now the gun works flawlessly. I still love thier Terror Chokes though. W. [ 01-10-2006, 12:34 PM: Message edited by: woodsie ]
  11. Just wanted to let you know that I replaced my Surecylce recoil tube with the Original recoil tube, and I replaced the Surecylce Magazine upgrade with the original. I hunted with it today for sea ducks, shot probably 25-30 shells, and not one jam. First time all year.I think I got it fixed.(knock on wood) Thanks again. W. PS. I will say Surecycle does make some awesome chokes.
  12. Thanks, I used the blue. W.
  13. I just replaced my surecycle Tube with the Factory, after many people and Benellis gunsmith suggested it, as it was not performing well. I put the facotry one back on, and used Locktight. Was I supposed to use Lock tite. Please let me now quickly if I wasnt:) Thanks, W.
  14. Thanks wallhanger. If I wanted to replace my surecycle springs and magazine springs, where would you recomend buying them from. Thanks W.
  15. I dont know if this couldve been the problem, but on my Surecylce upgrade magazine kit, I had the Red Plug in backwards. Do you think that couldve been the problem, or would that have now effect on it. THanks, W.
×
×
  • Create New...