Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Benelli Forums

jhartwig24

Members
  • Content Count

    2
  • Joined

  • Last visited

Community Reputation

10 Good

About jhartwig24

  • Rank
    Junior Member
  • Birthday 08/13/1982

Personal Information

  • Location
    NE South Dakota
  • Interests
    Hunting, Fishing, Outdoor activities
  • Occupation
    HVAC tech
  1. Hey guys, I am new to this site, but have been reading some posts and you all seem to have a great deal of knowledge and I am in need of some help. I have both an older Benelli Nova that was bought in 2000 and a Super Nova that was bought in 2008. With both guns I have had great success and I love them. First off, let me give you a little history. Ont the Regular Nova, I have around 8,000 rds through the gun. I have put in a new firing pin, a new hammer spring, and a new magazine spring. All of this was done 3-5 years ago. And have not used the gun a whole lot since getting the newer Super Nova. With the Super Nova, I have not had any problems with the gun, and have around 2,000-3,000 rds through it. I have not replaced any parts on the gun. Just kept it good and clean. Here is my problem. When using the guns over the past couple weeks snow goose hunting, I was having problems with both guns. Both guns are experiencing the same problem. When I shoot the first shell that is in the chamber and pump to eject, the second shell from the magazine will not enter the chamber on its own. I manually have to close the action, and hit the manual open action button to cycle a new shell into the chamber, it works everytime to manually cycle the action and get it to kick in the next shell, but it will not do it when shooting. I had this problem almost 95% of the time with my Super Nova, so I switched to my back-up older Nova and it did the same thing, but only about 40%-50% of the time. I have some down time now since the geese are gone, so I'm wanting to get this fixed before any other seasons open back up. Any ideas what is causing this? And how can I fix it on my own, if possible? Thanks so much guys for the help, I truely appreciate it! Jake
×
×
  • Create New...