Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Benelli Forums

wtrfwl801

Members
  • Content Count

    4
  • Joined

  • Last visited

Community Reputation

0 Neutral

About wtrfwl801

  • Rank
    Junior Member

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. After shooting the 2 boxes of Kents Loads, I tore down the gun and inspected for anything out of the ordinary. I've always noticed that the trigger assembly and associated components felt loose on this gun, so I decided to disassemble it. The first thing I noticed was that the Cartridge Drop Lever spring wasn't correctly seated in their groves, the spring had moved outside of it's flanges, where it was making contact with the receiver. The next thing I noticed was that the D-Clip was missing from the Carrier Pin, so the Carrier feels really sloppy. Perhaps this is a contributor to my intermittent StovePiping. I pulled the cartridge drop lever off, bent the clips and spring so they're better secured and re-assembled the trigger assembly. I've ordered a D-Clip from Midwest Gun Works, and I'll post the results once I have more shells through the gun and have installed a D-Clip, since it seems that the gun came from the factory without it.
  2. Posting a quick update: I found this thread on the forum from Wallhanger54 suggested grinding the ejector plate down 1/16". https://forums.benelliusa.com/topic/2849-sbe-ii-extractor-problem/ "Echo, I dont know if you got my message. I was going to say that if you remove the spring and ejector plate and grind the rear tab of it down to about a 1/16" it will allow more travel to the rear for the 3" and especially 3.5" shells. I have found that this clears up many stovepipe situations. Make sure you deburr and smooth the edges before you put it back in." I followed this guys advice and ground down my extractor plate about 1/16" of an inch, then went to the range and shot 2 boxes of Kents 1 1/8 ounce 3" loads though the gun. I didn't have a single jammed shell. I'm not ready to declare victory, but that's the most shots of 3" loads I've ever had from the gun. Here's a pic of the modified ejector plate:
  3. I have several Benelli guns as well. Super Sport, SBE2, SBE1, M1, SuperNova. My SBE2 has been a Lemon since day 1 and I feel your pain, it's an 1,800 dollar paper weight. I've done two warranty returns on it, it still has issues and doesn't eject shells properly. My 20 year old SBE1 has close to 50,000 rounds through it, it's an amazing gun. My SBE2 has maybe 1,000 and jams almost every other shell. EdWalton, are two shells being ejected from the magazine tube into the action when the bolt locks back? What kind of shells are you shooting when you experience the issue?
  4. I purchased a Benelli SBE2 25th anniversary edition 2 years ago with the intention of using the gun for waterfowl hunting while retiring my old 20 year old workhorse SBE1. From day 1, it began stovepiping with Kents 3" 1 1/8 ounce and 1 1/4 ounce loads. I field stripped, and cleaned the gun, shot Federal 3" Steel, Remington, I've had the issue with every name brand 3" of shotgun shell out there. 2 3/4 inch target loads shoot fine through the gun. Last year, I called Benelli and sent it back to them under a warranty claim. They replaced the extractor spring and the issue mostly went away jamming about 1 shell out of every 25 shots. I lived with it, but was never pleased with my results. This duck season in October, the issue came back more frequently than ever, jamming approximately 10 shells out of every box of 25 (Kents 1 1/8 ounce shells), plus it developed the new habit of feeding 2 shells into the action. The second shell only fires about 1 out of every two attempts after thoroughly cleaning the gun multiple times. Frustrated, I called Benelli and sent it back to them . They said the gun was "Dry" and had some white powder in the rear spring tube assembly, they oiled it and test fired a few rounds, then sent it back stating that they couldn't re-create the issue and the gun works great. First time out with the gun swan hunting after their "repair", it's 20 degrees Fahrenheit, and a flock of swans flies, the gun stovepipes again second shot and I missed the bird. Luckily I had more old workhorse SBE1 with me and my hunt continued without further issue. I've stripped and cleaned the SBE2 more times than I can count. The double feed issue seems to be resolved, but I'm back to a gun that can cycle three shells about every other volley. I'm using the Lucas Extreme Duty Gun Oil as Benelli recommended, tried Rem-Oil, MP-10, etc. Nothing changes the results significantly. To say that I'm frustrated with the gun and Benelli is an understatement. I don't see their"Test" firing procedures as being accurate simulations of real world scenarios. I bet their not putting the gun in the freezer or simulating any real world hunting conditions. (Wet, cold, muddy). Yeah, I'm shouldering the gun correctly as my SBE1 fires great. I'm considering using this guys idea of welding up the ejector tab to resolve the issue if I can't find any other suggestions. https://forums.benelliusa.com/topic/20876-sbe2-jams-with-kents/ "Well I think I fixed it. I blackened the rim of a case and when I ejected it, the ejector was barely making contact with the rim. I welded up the leading edge of the ejector and reshaped it so it would reach past the round edge of the rim and make contact with the face of the head. Maybe added .025-.030 of reach to the ejector tip. Haven't had any jams since. Have to put a few more boxes of shells through it to know for sure but it's about a hundred times better than it was." For those who say you should shoot a different brand of shell exclusively, Kent's shells are provided to me for hunting and they fire fine in my SBE1. Has anyone solved this issue before? Benelli hasn't put in due diligence to solve the problem for me.
×
×
  • Create New...