Jump to content

Nova not ejecting shells


Recommended Posts

My 1 season old Nova is only ejecting shells maybe 1 out of every 3 racks. The last day of duck season it started jamming, took it home, cleaned it and tried to run some dummies through it. The shells start falling before they can hit the ejector pin so they just sit back into the magazine. The result is it either doesn't come out at all, or it kind of anemically trickles out instead of really kicking out like it should.


I've disassembled and reassembled it several times, same problem. I've tried racking it really hard, normal speed, and not hard at all, problem persists.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...