Jump to content

Problem with Nova magazine jamming


The ORB
 Share

Recommended Posts

Hey folks, looking for a little advice. Back in January 2002, when I was living in the US I bought a Nova 12Ga pump in camo. I used it sparingly for a couple of years for various kinds of hunting and clays with no problems. Then after a move to Canada it sat unused in the gun safe for almost three years. I recently got licensed over here and went to use it at a local club shooting some clays with a couple of buddies. The gun shot great, only problem was that the magazine was jammed and wouldn't let me load any shells, hence I had to load individual shells by hand. No problem, I assumed it just need cleaning and lubricating. Anyway that afternoon I stripped it cleaned and lubricated the whole gun and especially the magazine components. Put it back together and it seemed fine, but then I tried it again the next day and it seemed to be jammed again. Any idea what might be the problem? I didn't notice any corrosion or damage and the gun is in great condition, but for some reason the little red plastic cup seems to be jamming at the end of the magazine tube and not allowing me to load any shells. Never had this problem before I stored the gun and the plastic part seems fine.

 

Thanks for any advice. :confused:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...