Jump to content

Can't load shell

Big Belly Dude

Recommended Posts

Hi, I'm a first time gun owner and I just took delivery of a new Benelli Nova Tactical 20051 last week. Today I tried loading the gun with dummy rounds. The shells cycle correctly. However, I can only put two 2-3/4 shells into the magazine tube. When I tried putting in the third, when half way in, it felt like it's already hitting the bottom. This is the first time I put shells into the magazine tube, and I'm sure there's nothing inside. Any tips? Thanks!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...