Jump to content

Crio Choke Issues?


Mr Ed
 Share

Recommended Posts

Was wondering if anyone else has had any issues with crio chokes on their SBE II?

 

Bought my gun last March and got it out dove hunting on Monday. Went to clean it today and it appears the chrome on the inside of the choke started to peel off. At first, I thought it was just plastic fouling from wads but after a thorough cleaning, I could actually see where there was chrome missing.

 

I was shooting with the IC tube #7 1/2 and #8 - 1 1/8 oz factory lead dove loads (both Federal and Remington). Probably put about 200 rounds through the gun (the doves were flyin' fast and there's no limit on Eurasian doves here in Colorado).

 

I've never had this happen - very strange.

 

No worries - I ordered another choke tube to replace it (hopefully I'll have it Friday so I can shoot more over the weekend)...was just wondering if this is a common issue and if I should carry backup choke tubes.

 

Thanks!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...