Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Benelli Forums

mcqjohn

Members
  • Content Count

    6
  • Joined

  • Last visited

Community Reputation

10 Good

About mcqjohn

  • Rank
    Junior Member
  • Birthday 05/19/1962
  1. I am having a problem with my 300WSM feeding reloads. A round loaded from the magazine will not seat past the extractor. The bolt does not go into battery, remaining slightly open, basically the distance of the round sitting on the outside of and on top of the extractor. If I drop the same round in the chamber, the bolt will close - the extractor will move around the cartridge. I have mic'd the base of the reloaded vs new rounds and there is only .001 difference between the two. The reloads are completely resized. The reloaded cartridges fits just fine in the chamber when manually placed there (no tight spot- drops right in). Factory ammunition exhibits no issues. Any input?
  2. I am having a problem with my 300WSM feeding reloads. A round loaded from the magazine will not seat past the extractor. The bolt does not go into battery, remaining slightly open, basically the distance of the round sitting on the outside of and on top of the ex tractor. If I drop the same round in the chamber, the bolt will close - the extractor will move around the cartridge. I have mic'd the reloaded vs new rounds and there is only .001 difference between the two. The reloads are completely resized. The reloaded cartridges fits just fine in the chamber when manually placed there (no tight spot- drops right in). Factory ammunition exhibits no issues. Any input?
  3. mcqjohn

    About 24 shots

    I have not had the same problem, my functions correctly.
  4. mcqjohn

    Tight Bolt

    That describes the same as mine is doing. I won't be concerned then. Thanks for the input. John
  5. mcqjohn

    Tight Bolt

    The gas piston is very clean. The "tightness" comes just when you try to open the bolt. It resists as you first pull to the rear, then its normal after that. Thanks for replying!
  6. mcqjohn

    Tight Bolt

    I've had my R1 300 WSM for a week. I did a detail cleaning today and discovered the bolt to be "tight" after reassembly. It loosened up after a few pulls. I re-read the manual and don't find anything I did wrong. Is this "normal" after reassembly, or is there something I should do about it? Thanks in advance. John
×
×
  • Create New...