Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Benelli Forums

murlow01

Members
  • Content Count

    1
  • Joined

  • Last visited

Community Reputation

10 Good

About murlow01

  • Rank
    Junior Member
  • Birthday 03/28/1986
  1. I bought this Benelli M4 used. The original owner said he shot 50 rounds through it. Seems to be true there was near no wear on the bolt. He upgraded the springs in the gun to reduce trigger pull Taran Tactical. I have shot several rounds through the gun. Every 3rd or 4th round the firing pin does not discharge the round. The firing pin strikes but not hard enough. The round has been hit clearly but not hard enough. I put the round into my cousin benelli super nova about 15 year old shotgun with like 10000 rounds through it and it fires perfect. I have tried 3" bird, 2 3/4" bird, double o, etc. Same thing everytime. Some of the more expensive ammo works fine but still have a problem every now and then. I have followed the Benelli lube tips in the manual. The gun is always very clean and well taken care of. I recently replace the firing pin spring. Still didn't fix the problem. Any ideas what is going on it is really pissing me off. What a cool gun one of my favorites can't wait to get it running correctly. Maybe i need a new firing pin? FYI the bolt seems slow to close like it is missing some power. Sorry if i am not using proper terms. I am new to this forum. I also apologize if this was already answered i was unable to find anything on this problem in this forum. Thanks for your help in advance.
×
×
  • Create New...