Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Benelli Forums
Chapo

M1-Feeding Problem

Recommended Posts

I recently acquired a used M1. When unloading the gun ejecting the round out of the receiver by hand, the second round coming out of the magazine sometimes only comes out about 3/4 of the way. With a little assistance the round will come out of the magazine. When shooting the gun it cycles fine. Anything I can do? Problems with the magazine spring? Thanks for any help.

Share this post


Link to post
Share on other sites
http://www.benelliusa.com/customer-service/pdfs/M1.pdf page 38 explains unloading and sounds you are trying to rack them out, they explain how they want ya to do it! chance of shell going off racking them thru i guess is why they say unload it the way the manual says?? Troubleshooting tree claims ya might need to put some extra lube where bolt hits the cup in the back of the reciever?? probably not an issue here but try!

Share this post


Link to post
Share on other sites

I had that same problem with my Monte. Turns out the problem was not enough lube on the inside of the magazine. If you push the stopper part way down with your finger, spread a little lube in there and then load and unload the mag several times, it should work just like new. Chances are that your spring is not faulty, plus, I believe that the mag. tube is held with red lock-tight, which would require gun-smithing to fix problem.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...