Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Recommended Posts

I just purchased one of the pre-ban M3 police trade in topfolders that CMMG is selling. These weapons had been converted by the police department to semi auto only. I ordered the part to convert it back to its original configuration.

 

Tonight, I took the gun apart and installed the new selector. I thought I had done everything right, including winding the selector return spring back around the selector and everything else.

 

Now, I can't get the gun to switch to semi-auto. It works as a pump (although the bolt does not come forward with the slide - is that normal?), but an attempt to switch it to semi results in the return spring sending the selector back to pump.

 

Does anyone know what I am doing wrong? Did I reinstall something incorrectly? I was very

careful.

Link to post
Share on other sites
  • 10 months later...

Sounds like the spring that keeps tension on the "selector" to lock it in the Semi auto mode, may be wound backwards.

The bolt closes when you hit the bolt release to close the bolt, even when in the "pump" mode, unless there is a shell in the chamber, then it works normally. That is the way mine works.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...