Jump to content

Cycling Problem


Recommended Posts

My problem is somewhat more complicated. Once I chamber a round and release the second, the third will not release from the tube after firing the first two. I have broken down the shotgun and inspected the moving parts, and all seem to be fine, but when I put it all back together again, it still won't load the third shell. Is there a trick, or is my SBE broken.

 

P.S. I bought the gun after it was used for duck hunting for two seasons, so the break-in period is not the problem?

Link to post
Share on other sites
  • 2 weeks later...
  • 3 years later...
My problem is somewhat more complicated. Once I chamber a round and release the second, the third will not release from the tube after firing the first two. I have broken down the shotgun and inspected the moving parts, and all seem to be fine, but when I put it all back together again, it still won't load the third shell. Is there a trick, or is my SBE broken.

 

P.S. I bought the gun after it was used for duck hunting for two seasons, so the break-in period is not the problem?

 

Why do you release the second shell after chambering the first shell? Just curious.

 

I doubt your Benelli is 'broken'. You might have a bent magazine tube, weak magazine spring, dirt or grit in the magazine tube that is binding the follower, a damaged follower, etc.

 

I tried the magazine kit from Sure Cycle, but it caused too many problems, so I went back to the factory parts.

 

I would take the gun apart and try dropping the follower down the mag tube to see if it gets stuck anywhere. If the mag tube is bent, you may want to order a new tube or send back to Benelli for repair.

 

With the bird hunting seasons just a few days away, don't expect Benelli to work on your gun right away and get it back to your quickly.

Link to post
Share on other sites

Wow! After it was used for 2 duck hunting seasons? Duck hunters can be the hardest on guns... not cleaning them and such. I would suspect the magazine assembly. Just check to make sure the follower isn't in backwards. I have seen this happen many times after someone has cleaned the gun and had trouble on the last round. It doesnt help the fact that Benelli insists on putting that crappy plastic follower in either. Also, just try to operate the gun normally (2 in the mag, 1 in the pipe) to see if it works that way.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...