Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Recommended Posts

Greetings, I am new to Benelli, so I don't really know much on what makes them click per say.

My issue I picked up this Nova Tactical that has a extension tube . I have taken her apart clean and lubed ( it appears it was never shot) I can load 7 2 3/4 shells, open the chamber and insert the 8 th. When I go load a shell the one in the chamber ejects the 2nd round shoots out the bottom and when I go to rack it again the 3rd round loads perfectly .

can somebody who knows these shotguns please tell me what I am doing wrong, it does the same with 3" as well

 

thanks in advance from a Benelli newbie

Link to post
Share on other sites

There's a YouTube video that looks like it specifically addresses this problem. Apparently there was some manufacturing issues, which caused a small piece of material to keep the flap up. Filing it down will fix it. The video is here:

Link to post
Share on other sites

Thanks CD for the video, I got in touch with Benelli CS (need to call first thing in the AM to get them) they gave me a RMA to send it in to be repaired(2to 3 weeks).

benelligunny diagnose the problem with my Nova. I am lucky since mine is a import I'm covered beyond the 10 yr warranty give by Benelli......

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...