Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Benelli Forums
Sign in to follow this  
benelli1014

Finally installed a 7 round titanium tube (my experience)

Recommended Posts

So I ordered a CarrierComp titanium tube in mid March and got it about 2 weeks ago so (about 2.5 months). After reading SD's instructions and watching a couple of videos, I bought a vise, Wagner $39 heat gun, and 243 loctite. I preheated the heat gun for few minutes on max, then applied the heat for about 2-3 minutes. That's all it took. I was wearing nitrile gloves to keep hands clean and extra grip. I was able to untwist the tube with one hand with minimal effort (I guess they didn't put much loctite on mine at the factory). I cleaned the receiver with a brass brush, put a little bit of 243 on the threads, installed the new follower, spring, and reinstalled snap ring with snap ring pliers. It was a lot easier than it looked like some of you said.

 

PS: Stupid autocorrect keeps changing loctite to lactate. If I missed one, just wanted to mention that no location occurred during the process ;)

Edited by benelli1014

Share this post


Link to post
Share on other sites

Good for you and welcome to the cadre of do-it-yourself mag tube installers! When I did mine, I first tried a regular 1500W hair dryer on it and that did the trick so I didn't have to buy anything.:D

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...