Jump to content

Montefeltro Won't Cycle, Any Ideas


Big Nige
 Share

Recommended Posts

I have a six month old Montefeltro that has performed faultlessly on light clay loads for 3,000 rounds at least, unfortunately it has now started not cycling, any ideas would be welcome, the gun is well and truly broken in now and I might add it is absolutely perfectly clean, I'm wondering if now the springs have settled in it will never cycle these types of loads again, has anyone had similar experience? Many thanks.

Link to comment
Share on other sites

clean gun needs quality lube, what kinda lube do ya use? has trigger group been taken down and cleaned with solvent,brushes? Is your problem an occasional FTC or repeated? for people to help, ya gotta fess up ALL the info and not only info you think someone wants to hear? could be mechanical issue and would call benelli and ask Tech not Secretary plus they do not SELL anything to CONSUMERS!! never have never will!!

Link to comment
Share on other sites

I have removed and cleaned both the trigger group and bolt 3 times with light compressed air and Leggia spray, take it from me they are "as new" clean , as is the chamber , the problem is as follows , after the first round is fired the spent shell is always ejected and the next round from the mag gets hung up somehow between the floorplate and the barrel , if you then push the floorplate the round slips nicely into the chamber , that is how it happens everytime.

Link to comment
Share on other sites

Leggia Spray? guess i am clueless on that, not surprised?

http://www.benelliusa.com/customer-service/troubleshooting.tpl have ya looked at these and tried to see if anything here would solve issue? what kinda Oil/lubed do ya use? also what kinda sheels ya talking about one specific type or a combination of all? lotta shells are just not quality made and will not shoot in these shotguns? but when ya broke in your shotgun did ya do it with light loads?

Link to comment
Share on other sites

Legia spray is made by browning , this gun is mint clean in all areas [as I have already said] including mag tube and recoil spring , it has only ever had the same make of shell thru it , it has cycled 3,000 perfectly and now ftc 1 out of 6 , its worse if there is only 1 shell in mag pointing to perhaps a weak mag spring but I must add it feels fine and strong to me, in fact quite a bit stronger than the one on my A5 which never fails, I dont think there is anything wrong with it other than the springs have settled , when they were brand new they just had that little bit extra in them to cope with light loads

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...