Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Benelli Forums
sctiger11

SBE II Sling Problem

Recommended Posts

My SBE II just came in today and I already noticed that my old strap isn't going to do the job. It looks like the connecting swivels of the old strap are going to chip away the paint on the fore-end cap. Has anyone else experienced this problem and if so, how did you fix it. Duck season starts in a few days and I'd hate to scratch up a brand new gun already. What types of slings do yall use that work?

Edited by sctiger11

Share this post


Link to post
Share on other sites

Its not a problem, just mount your sling and be happy. I have a sling on mine, after 3 or 4 seasons of using it I havnt seen any damage to the end cap. Scrapes, scratches. rubs, nothing.

Share this post


Link to post
Share on other sites

One of my Benelli guns, I think the R1, came with sling connectors. Not all of the guns do. Some of the guns come in a hard plastic case, and others come in card board boxes. I will take what I can get, but the proper connectors do exist and they work with the gun. I couldn't upload a photo here so I put one over here http://www.sffchronicles.co.uk/forum/members/tinsel-albums-various-2010-picture775-sbe-ii.html >. You can see the Benelli sling connector fairly well on the stock.

Share this post


Link to post
Share on other sites
My SBE II just came in today and I already noticed that my old strap isn't going to do the job. It looks like the connecting swivels of the old strap are going to chip away the paint on the fore-end cap. Has anyone else experienced this problem and if so, how did you fix it. Duck season starts in a few days and I'd hate to scratch up a brand new gun already. What types of slings do yall use that work?

I've noticed this also. The swivels that worked fine on my M1S90 don't work so well on my SBEII because of the shape of the fore end cap. I've tried several types of swivels but haven't found any that don't rub on the end cap. It's annoying but I've learned to live with it.

If you happen to find swivels that solve this issue, please let us know.

Share this post


Link to post
Share on other sites
I've noticed this also. The swivels that worked fine on my M1S90 don't work so well on my SBEII because of the shape of the fore end cap. I've tried several types of swivels but haven't found any that don't rub on the end cap. It's annoying but I've learned to live with it.

If you happen to find swivels that solve this issue, please let us know.

 

I am fighting this same issue.. The sling mount not only will eventually mar/chip the camo finish on the mag cap but mine makes a bad popping noise as it moves with each step. I've dug up several old threads and started one new one about this. I've also emailed Benelli. I'm actually wondering if everybody with the problem has the noise?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...