Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Benelli Forums
Sign in to follow this  
z71rad88

SBE2 not firing and tight mag spring

Recommended Posts

Has anyone else had an issue where their gun wouldn’t fire on the first round after you’ve noticed the magazine spring being really stiff to the point it won’t take the round? My SBE2 has been absolutely flawless the past 13 season and this year it’s been quiet the opposite. I’ve changed the recoil spring to a Wullf 25% because I was getting a “click” when I’d pull the trigger to I assumed the action wasn’t closing all the way. I then proceeded to replace the firing pin spring as I was still gettin a “click” and no indentation on the actual prime. 

I don’t know what else could be causing the round to not go off. It’s worth mentioning this is an inconsistent issue. Sometimes it’ll go, boom, boom, boom. But other times, the first round won’t go click and the only other way I can offer more detail in hopes someone can assist me is I seem to notice this happen when I get a stiff magazine spring while loading my second round. I’ll take the round out and try again and again until it takes it. Then when I go to shoot, “click.” 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...