Jump to content

SBE won't eject 3.5 kent fasteel


shell waster
 Share

Recommended Posts

Need help, my SBE won't eject 3.5 kent fasteel. I think the gun jams in the following manner. You shoot, the empty casing is being extracted, but the extractor slips off the bottom of the brass lip of the shell, the bolt keeps travelling back forcing the Carrier to pick up the next round, hence jamming the gun because an empty shell is in the action and the next round is trying to get in. It does not do it with every round of fast steel, but it is at least 20-30%. I bought some cheap 3.5 Xpert HV, 25 rounds without a hick-up. Is anyone else having this problem or has a solution. I have used fast steel before with no problems, now I have 4 boxes sitting on the shelf because I have no confidence with the stuff. No prblems with 3 inch shells. The action cycles all the way with the fast steel. Pleas advise.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...