Jump to content

Diagnose My Jamming Issue (Pics attached)


cdogg44
 Share

Recommended Posts

I've got a 5 year old left handed SBEII with a couple thousand rounds through it. I shoot everything with it, from skeet to geese. I can't ever remember it jamming on me until this season, and I've had 3 jams that were the exact same and at totally random times. It happened again today and I took some pics with my phone.

 

Shells today were 3.5" BB's Winchester Xpert (cheap....I know), but it has done the same with 3" shells.

 

What is happening is the shell is not coming all the way out of the magazine tube and is hanging the gun up.

 

I should add that I've never had the magazine tube apart until this year, when I test installed an extension tube I'd bought for snows. After the first two jams this year I disassembled the mag tube and cleaned it up real nice and the gun has been perfect since, until today. The gun has seen everything from 8 degree weather to freezing rain this year and has been flawless except for 3 jams (on clear ~35deg days). Of the 3 SBEII's in our group mine is the least problematic. I maintain it, but I'm not an obsessive cleaner.

 

 

http://i670.photobucket.com/albums/vv65/cdogg44/IMG00140-20100130-0908.jpg

 

http://i670.photobucket.com/albums/vv65/cdogg44/IMG00144-20100130-0911.jpg

Link to comment
Share on other sites

I've got a 5 year old left handed SBEII with a couple thousand rounds through it. I shoot everything with it, from skeet to geese. I can't ever remember it jamming on me until this season, and I've had 3 jams that were the exact same and at totally random times. It happened again today and I took some pics with my phone.

 

Shells today were 3.5" BB's Winchester Xpert (cheap....I know), but it has done the same with 3" shells.

 

What is happening is the shell is not coming all the way out of the magazine tube and is hanging the gun up.

 

I should add that I've never had the magazine tube apart until this year, when I test installed an extension tube I'd bought for snows. After the first two jams this year I disassembled the mag tube and cleaned it up real nice and the gun has been perfect since, until today. The gun has seen everything from 8 degree weather to freezing rain this year and has been flawless except for 3 jams (on clear ~35deg days). Of the 3 SBEII's in our group mine is the least problematic. I maintain it, but I'm not an obsessive cleaner.

 

 

http://i670.photobucket.com/albums/vv65/cdogg44/IMG00140-20100130-0908.jpg

 

http://i670.photobucket.com/albums/vv65/cdogg44/IMG00144-20100130-0911.jpg

 

Did you get a new spring when you got that extension tube? If you just put the stock spring back in to a longer tube that could be your problem. It looks to me like the mag spring just doesnt have enough power to throw the shell onto the carrier before the carrier tries to go up again, you might look into getting a new mag spring.

Link to comment
Share on other sites

Did you get a new spring when you got that extension tube? If you just put the stock spring back in to a longer tube that could be your problem. It looks to me like the mag spring just doesnt have enough power to throw the shell onto the carrier before the carrier tries to go up again, you might look into getting a new mag spring.

 

The extension I bought is huge, like +6, and came with a bigger spring.

 

However, I'm running the gun normal right now (no additional extension) with the stock spring and plug in it. I was thinking a stock mag spring would last longer than ~2-3k rounds.

Link to comment
Share on other sites

Take the plug out. See if this jam happens when the magazine tube is full vs. near empty. This will indicate if it is a weak magazine spring.

 

Next. Try limp wristing it on purpose. Does this increase the rate of failure?

 

It is possible that the recoil spring is weak. Replacing mine cured my sluggish performance in a different model than you have.

 

Also, check the bolt release for damage. Its paw is what releases a shell from the magazine tube.

 

Further, inspect the magazine tube for dents. Check the follower also. Ensure that the plug is not binding in the tube and causing failure.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...