Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Test


KB Fab
 Share

Recommended Posts

So I talked to Benelli early last week. I talked to a nice enough guy who seemed interested that I had taken the time to report what was going on. He took my name, email, and forum user name and was going to forward my info to the web folks.

 

I told him about all the problems that have come up recently with posting as well as the threads that disappear due to various things. He said they have just upgraded to the latest vBulletin software and it has a bunch more spam stuff that he said more than likely is causing the issues. I think that's probably accurate and there is no one in charge who really understands the new software. I used to run a welding forum and am pretty certain that it's just a matter of going in and tweaking the default settings but getting someone to do it seems iffy at best. Hopefully someone there will step up. I also told him that there are plenty of old timers here who would be interested in helping moderate the forum so, who knows what he'll do with that.

 

If you really want to get this BS worked out, I would suggest giving Benelli CS a call and doing exactly what I did. If enough of us do it then they may just fix it. I hope.

 

Benelli CS phone number =(301) 283- 6981 or (800) 264-4962

 

IMG_0909.jpg

Edited by KB Fab
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...