Jump to content

I have the A & S trigger guard and when trying to load double it seems to not click in unless i push really hard.


Jaason0
 Share

Recommended Posts

I am using the freedom fighter follower and wolf tube spring. If I load singles it is easier but almost seems like something in the way preventing it from going as smooth as I hoped. Anyone have a solution or is that just way it is? Does the follower make a difference? I am gonna try putting the OEM tube spring in and see if that helps

Link to comment
Share on other sites

I am not extremely well versed in the M4 yet, but mine is the same trying to double load.  I am pretty sure that my issue is the shell stop/spring - not the A&S guard.  It is just not worn in yet so the shell stop is pretty stiff to get past.
I read on the forums previously that some guys have polished the shell stop but it is a fine line between polishing to make it feed better and taking too much material and then the shell stop does not work properly.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...