Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Problem with 20 ga Montefelthro


Recommended Posts

  • 2 weeks later...

try and check if the bolt is closing all the way. also check to see if the feed ramp is hanging up on the inside of the recever any where. if its well used there may be either too much play in a spring some were or a burr hanging up the bolt.

Link to post
Share on other sites

Ok.. fake punt. It's all so clear to me now.

 

taking fezmans advice and finding a few things here and there then looking at my brothers Monte.... it sounds as if your recoil spring is worn out and short cycling causing the second shell to 'sneak' into the reciever. It's been recomended by one of the guys here that a Wolffe spring (not factory) is the way to go and a yearly cleaning and use of synthetic lubricant on the recoil spring is key.

 

You may want to replace the hammer spring and magzine spring while you're at it since its been around the block a few times.

 

But my moneys on the recoil spring being your main concern/problem.

 

hope this helps...Good luck.

Link to post
Share on other sites
  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...