Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Benelli Forums

Search the Community

Showing results for tags 'problem'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • General Discussion
    • Benelli
    • Waterfowling
    • Turkey Hunting
    • Big Game Hunting
    • Upland Game
    • Shotgun Sports
    • R1 Rifle

Calendars

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Biography


Location


Interests


Occupation


loginname


displayname

Found 5 results

  1. Recently purchased a used 12 gauge nova from a pawn shop. Was cycling rounds through it after I brought it home and noticed the pump does not lock when the gun isn’t cocked. Might sound weird but if I pump it once the action stays in place like it’s supposed to. But if I fire it the pump wants slide back on it’s own. It’s annoying because I have to hold the slide up while chambering the first round otherwise the slide is too far down to insert the first shell into the tube. Any ideas on what it could be? Wondering if I should try to take it back?? Thanks for the input.
  2. Hello, I have been having a problem with my Super Black Eagle 2. The problem is that while I am hunting I pull the trigger and a shell gets put onto the carrier, but the shell in the chamber hasn't gone off which leaves me not being able to shoot and just clicks. Any help on what the problem might be would be appreciated.
  3. I purchased my Vinci and another gun at the same time at Gander Mountain - which has provided awesome customer service through this whole process. I am currently on my second Vinci since I experienced an approximate 10-15% misfire of my shotgun shells - which were the Winchester Xpert Hi-Velocity 3" shells. With my first Vinci, I went on three major, 5-day duck hunts. During these hunts, some different, yet similar failures were happening: 1. At first I was having periodic misfires with the first shell. Simply pulling the trigger, all I would hear was the 'click' of the firing pin, and of course, there was an associated firing pin indentation in the primer. The indentation was faint and obviously not strong enough to fire the shell. This happened a handful of times. 2. Occasionally, the 'click' of the firing pin on the first shell in the gun would not even leave a firing pin indentation at all. When these misfires of the first shell occurred, I was eventually more prepared and would quickly pull the slide back, ejecting the shell and loading the second round in the chamber which would then fire. 3. In the beginning, all misfires occurred only on the first round, however, at the end of my second hunt, I also experienced a misfire (hearing the firing pin 'click' and no indentation on the shell) on the third round. This misfire occurred after attempting to fire three rounds in succession. The gun was disassembled and thoroughly cleaned after every use. Gander Mountain(GM) was contacted after each hunt as well as the gun being brought into their in-house gunsmith. Neither any of the sales reps or gunsmith heard of this or any problems with the Vinci thus far and only a guess as to what the problem may be. They suggested that the 'machined groove' (on the barrell) that the bolt locking head could have been dirty and did not provide good shell:firing pin contact. This was the only thing that we could collectively come up with and I was sent out in the field to try it again after the first hunt. I did not have much faith as the gun was thoroughly cleaned after each use. As, described, the problem continued. I contacted Benelli which was quick to offer to send out a new firing pin and spring, however, I knew that there was something else going on and that it would not solve the problem. GM also contacted Benelli to find out what they wanted to do; they did not hear back from them and GM simply replaced the Vinci with a brand new Vinci. Well, I just got back from another duck hunt. I shot only 23 rounds through the gun and had two misfire (first shell only) as well as one feeding problem where the third shell and carrier would get stuck. Again, this is nearly a 10% failure rate. During this trip, I realized what I believe is to be the problem. When the bolt is automatically and/or manually put in the forward position (ex, loading a shell), sometimes the bolt locking head is not in the proper position. When the bolt (action) is properly closed, the bolt locking head (BLH) actually turns a bit counterclockwise as it gets seated into the machined groove on the barrel. I noticed that sometimes, the bolt locking head is not turned - thus preventing enough of a gap between the shell primer and the firing pin. The photo below is the proper position of the bolt locking head (note this by the ejector on the BLH): Below is what I believe is happening when the gun misfires, whether it is the first or third shell - compare the position of the ejector to the picture above! Finally, the last picture (not shown since there is a limit of two photos per post) is duplication of how the shell got hung up in the carrier and does not pushed all the way into the chamber. This failure only happened once in the last 20 or so shells. This is the first Benelli that I have ever owned. Two other hunting partners bought the Winchester Super X3 and the Beretta Xtrema 2 have shot a season of trap and season of hunting without a hitch. It is a bitter-sweet purchase. For my first semi-auto, I would never imagine that I would have these problems for the amount of money it costs. Has anybody else had any problems at all in the field with this gun. I will be taking the gun back to GM tomorrow to see what they think. I will also be contacting Benelli in the near future to get their opinion on this problem. I hope that since it is a brand new gun this year, that maybe there was a quality control issue or something that has now been straightened out. I will check out some other blogs to see what others are saying....good luck.
  4. I am having an issue with my Nova feeding the next round. When I have a round in the magazine and go to cycle that round into the chamber, the shell elevator does not go all the way down and blocks the round from sliding back onto the elevator so it can be cycled into the chamber. Sometimes I can work the elevator while pumping and sometimes while I do that the round falls out. What is weird, is it seems that when I dry fire the gun and try to cycle a round, everything seems to work fine. I have read a lot about the SuperNova having this issue and I have also read that this is a safety feature with the Nova Pump. Ideas? Help?
  5. error - deleted
×
×
  • Create New...